Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 25, 2026 - 02:00 BST
Scheduled
Holiday Taxis will be carrying out platform maintenance. As a result, clients and customers may experience increased latency and elevated error rates during the maintenance window.
Posted Apr 21, 2026 - 11:48 BST
This scheduled maintenance affected: Agent Site, Check Pickup, HBX Bridge, PayLink, Public B2C Website, Supplier Connect API, Supplier Portal, URL Shortener, Webservices 2.0 and Internal (Admin, WLSS).